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This set of instructions is designed to help current users of ASAPprime® v5 

transition to the newly released v6 of the software. These instructions are 

appropriate for users who already have a good understanding of the use of 

v5 and only wish to learn about the new functions. For users with no prior 

experience wanting to be trained on the use of ASAPprime®, or those who 

feel they need more extensive explanations on how to use the new 

features, we recommend our full day training program. To get information 

and a price quote for this training, please contact: Dave Lucey, Business 

Development Manager, david.lucey@freethinktech.com. 

These instructions do not go into details on the algorithms and theories 

employed, rather they are designed to be operational. For details on these 

algorithms and theories, please contact FreeThink Technologies 

[tech_support@freethinktech.com].  

ASAPdesign™ 
There are only minor changes made to ASAPdesign™ in going from v5 to 

v6 of ASAPprime®. The first of these changes is that when one has a very 

stable product (e.g., a crystalline material), there is an option to check the 

Very Stable Product checkbox in the Prior Knowledge window (Figure 1). 

This pushes the design itself to very harsh conditions (within the allowable 

condition space). We assume that the stable product will need these harsh 

conditions to get the product to hit its specification limit. In the cases 

where even the harshest conditions cannot induce product failure, the 

degree of harshness will impact the minimum shelf-life that can be 

established. 

While v5 of ASAPdesign™ had the option of three levels of confidence in 

prior data, v6 has added a “very high” confidence level to the Confidence 

in Estimated Parameters drop-down menu (Figure 1). The higher 

confidence level establishes a narrower design space around the mean 

predicted isoconversion times at each condition. 

 

 

New Data for Packaging 
In the main ASAPprime® program, several new excipients have been 

added to the drop-down menu based on moisture sorption isotherm 

measurements done at FreeThink. Additional synonyms have also been 

included for some common excipients. 

Error Bar Calculations 
A major change was made to the error bar (and corresponding probability) 

calculational methodology. In v5, an error bar for each isoconversion time 

(calculated using an extrema method) was the basis for Monte-Carlo error 

bar propagation using the Arrhenius or moisture-modified Arrhenius 

equation. In the example shown in Figure 2, the isoconversion rates 

(represented by the three data points) are not well-modeled; i.e., fall 

outside or on the outer edge of the model error (red line).  This is because 

each point has a small error bar which results in a relatively small overall 

error based on the Monte-Carlo (MC) calculation. The error of the fit 

(illustrated by the green line) shows a wider error.  

 
In v6, a new algorithm takes the square root of the sum of the squares of 

the errors from the Monte-Carlo propagation (the only error bar used in 

v5) and of the fit itself: 

𝜎𝑡𝑜𝑡𝑎𝑙 = √𝜎𝑀𝐶
2 + 𝜎𝑓𝑖𝑡

2  

In some cases, this new calculation algorithm will result in significantly 

larger error bars which in turn will impact the probability of passing. 

However, when the fit is poor, the confidence interval will be increased 

such that there is more likelihood that the true value lies within the error 

bars.  

Because of this improvement in the calculation of the confidence interval, 

while the mean shelf-life values remain the same, there can be differences 

between the probability of passing calculations in v5 as compared to v6 

(see Figure 3). If a client needs results from an older version of 

ASAPprime® (for example, for a regulatory filing purpose), FreeThink 

maintains an archive of all prior versions and will provide appropriate 

support. If the calculations are not being used for regulatory filings, we 

would advise using the most up to date release. 
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Figure 1  ASAPdesign™ Prior Knowledge 

Figure 2 New Model Fit Error Bar Calculation Method 
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Figure 3 

 

 

 

 

Error Bar Display 
 

 

Confidence Interval Display 
In ASAPprime® v5, the displayed confidence interval on the degradant vs. 

time plot was always set to one standard deviation (i.e., 68.2% of the time 

the true value is predicted to lie within the interval shown). That meant 

that where the green line hit the specification limit, there was an 84% 

probability of passing and where the red line hit there was a 16% 

probability of passing (interval is 84 - 16 or 68%). With v6, additional 

interval choices are available for the display. This option can be accessed 

from the main menu bar under the “Options” drop-down (Options →  

Isoconversion → SD Method). There is an additional option that contains 

new available intervals: one SD (84-16% probability), 80% (90-10% 

probability), 90% (95-5% probability), 95% (97.5-2.5% probability) and 

99% (99.5-0.5% probability). 

Results Comparison 
The graph in the new Results Comparison dialog box (reached from the 

main menu bar under Tools → Results Comparison) has changes the graph 

to consider the isoconversion fitting model (Figures 4, 5). Since the data 

are still fit using isoconversion, this will only approximate the behavior far 

from the specification limit; however, when the fitting model is non-linear 

(e.g., Avromi-Erofeyev or Diffusion), the comparison should provide a 

better fit to the long-term data. It is recommended to use the fitting model 

that was used in the main program, but the displayed graph has the option 

to use different fitting models for the long-term comparison than used in 

the isoconversion fitting itself. The program also now provides a way of 

quantifying the quality of the fit of the long-term data to the model. The 

Mean Absolute Percentage Deviation value represents the absolute value 

of the average difference between the predicted and long-term values as 

a percentage of the values. 

 

 

 

 

 

 

 

 

 

 

 

 

Glass Transition Temperature 
A new tool under “Properties” (from the main menu bar: Tools → 

Properties → Glass Transition Temperature) provides a calculation of the 

glass transition temperature (Tg) as a function of RH (Figure 6). This 

calculation is appropriate for amorphous materials (typically an API or a 

dispersion). The calculation is based on the moisture sorption isotherm for 

the amorphous material under consideration in the Dosage panel. That 

Using 𝝈𝒕𝒐𝒕𝒂𝒍 =

√𝝈𝑴𝑪
𝟐 + 𝝈𝒇𝒊𝒕

𝟐  

 (ASAPprime® v6):  

83% probability of 

passing 

Using only MC 

calculation 

(ASAPprime® v5):  

93% probability of 

passing 

Figure 5  ASAPprime® v6 New Results Comparison:  

These same data are again fit to Avromi-Erofeyev, but the long-

term data are also fit to the same function. 

Figure 4  ASAPprime® v5 Results Comparison: 

In this example, the isoconversion model was built using Avromi-

Erofeyev, but the long-term data are fit to linear. Note that the 

intercept with the specification limit is accurate but not the other 

points. 
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means that using moisture sorption isotherms for the entire formulation 

will not be appropriate. This calculation assumes that moisture plasticizes 

the material (lowers the Tg) as a function of the water content. The option 

exists to have the conditions (T/RH) used in the study be displayed on the 

graph. This shows whether some of the conditions are potentially a 

problem for going from glassy to rubbery state and presumably could have 

discontinuous behavior (often more stable than expected because of 

crystallization).  

 

 

Dew Point Temperature 
Another new tool under “Properties” (from the main menu bar: Tools → 

Properties → Dew Point Temperature) is useful when a packaged solid 

undergoes a sudden temperature drop (Figure 7). In this situation, the RH 

inside the packaging will spontaneously increase. If the temperature goes 

below the dew point, the RH will be above 100% and result in moisture 

condensation. This condensation may lead to issues with the product 

including sticking, disintegration failures and chemical instability. The dew 

point temperature tool allows users to establish a safe low temperature 

excursion condition with respect to condensation: if the temperature does 

not drop below the dew point, there is little to no risk for these stability 

concerns. Since the RH inside a packaging will not, in general, be constant, 

the dew point will change with time. It should be mentioned that even if 

condensation occurs, there still may not be a stability issue. 

 

Deliquescence 
A final new tool under “Properties” (from the main menu bar: Tools → 

Properties → Deliquescence) calculates critical relative humidity (CRH), 

i.e., the RH above which a sample will condense moisture from the air to 

form a solution (Figure 8). Any material in a formulation that is highly 

soluble can be responsible for deliquescence when exposed to high RH 

conditions. As this represents a phase transition, it is likely that above the 

CRH there will be discontinuous behavior. Since the solubility of a material 

is most often temperature dependent, the calculated CRH as a function of 

temperature can be used to identify stress or storage conditions that may 

be problematic (use “Show Conditions” to display the conditions for 

which the degradant/potency data (T,RH) are entered in the main 

program). 

Figure 8  Deliquescence: Calculation of Critical Relative Humidity (CRH) 

 

Stability Analysis—Checkboxes 
Sometimes it can be useful to remove a specific data point(s) 

(Time/Temperature/RH) in the primary dataset from the ASAP analysis 

(degradation or potency) without permanently deleting the data. For 

example, a point may be an outlier, due to a sample analysis issue. The 

new checkbox option (Figure 9) allows the user to do this. This can be 

accessed from the Degradation table (by right clicking, selecting “Stability 

Analysis”, then using the tabs at the top to select “ASAP Data”). The actual 

removal of the points from the analysis does not occur until the user 

selects “Update and Close”, where the user is returned to the main 

interface. Note that if “Close” is selected, no update is performed before 

returning to the main dialog. The ASAPprime® report (from the main menu 

bar) can include the full original dataset and indicate which points were 

omitted from the modelling. 

 

 

 

Uses isotherm to 

calculate. Note that 

this will not be 

accurate for the API 

if isotherm for 

product is loaded 

rather than for the 

amorphous API 

material. 

At 1 year, if temperature 

drops below 11°C, there is a 

risk that condensation will 

occur and affect product 

attributes 

 

Blue line 

represents the 

calculated CRH 

Figure 7  Dew Point Temperature 

Figure 6  Glass Transition Temperature (Tg) Calculation Tool 

Figure 9  Checkbox for Individual Data Points 

Data from 21d/52.3°C/49.7%RH will not be used in the modelling 
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Similarly, it can be useful to remove an entire condition (T/RH) in the 

primary dataset from the ASAP analysis without permanently deleting the 

data. For example, one might consider that a particular condition is above 

a phase boundary. This is handled using the Isoconversion tab from the 

Stability Analysis (Figure 10).  

 

 

 

Data Evaluation 
ASAPprime® v6 now contains two options for evaluating primary data. The 

first option (Option 1) allows the program to directly take actions (such as 

removing points or conditions) without the user’s input. Because the 

actions are taken without user input, the program is very conservative 

about removing points or conditions. This option is especially useful when 

data analysis is carried out as part of a cGMP process. In other words, the 

program can remove points/conditions under its set algorithm rather than 

based on what might appear arbitrary if conducted at the user’s 

discretion. To access this option, the user enters the “Tools” dropdown 

menu from the main menu bar. From this pull down, the user selects 

“Evaluate Model” and “Original Data”.  ASAPprime® v6 removes points 

and conditions based on its algorithm. The evaluation results are accessed 

from the “Stability Analysis” by right-clicking on the Degradation Table. 

 

 

 

 

In the second option (Option 2), the program provides advice, but the user 

can elect to use or ignore each suggestion (Figure 11). This option is 

accessed by right clicking in the Degradation table, selecting “Stability 

Analysis”, then going to the “Analyze” tab. After clicking on “Evaluate”, 

the program returns analysis results which can be printed or saved (note 

that this table is also populated when running Option 1). The 

recommendations and rationales should be carefully examined, and 

decisions made on which suggestions to apply. In order to put into effect 

recommendations, the user clicks on “Implement”. This opens a window 

with the suggested data points or conditions to be removed (Figure 12).  

Checking the boxes and then clicking “Accept” will execute the changes to 

the modeling data set.  

Figure 12 Implementing Recommendations 

 

Low Conversion 
When data for all conditions cannot be distinguished from noise, 

ASAPprime® v6 provides a conservative calculation to determine a 

minimum shelf-life. The low conversion calculation window can be 

reached either through the “Evaluate Model” or Tools → Low Conversion.  

In each case, the user is prompted to either use data as if all points were 

checked on (“Original Data), or to use the current set of checkbox-

indicated data (“Current Data”). 

The Low Conversion algorithm will be invoked if all the data points at every 

condition are within 1.645 times the SD of the mean of the points at the 

condition. The SD used is that of the control point. In other words, the 

program will go into this calculation space when all conditions show data 

that is hard to distinguish from noise. 

While the data cannot be distinguished from noise, there remains a 

possibility that in fact there is low degradation occurring, just not enough 

to detect. This information plus conservative estimations of Ea (and B) are 

used to set the conservative probabilities. Reducing the LOD (or SD) may 

result in the program concluding that the data are no longer noise or 

extending the shelf-life. Users can adjust the assumed Ea and B values 

(Options → Isoconversion → Low Conversion). The default assumes an Ea 

(11.5 kcal/mol; 48.1 kJ/mol) representing a lower Ea than 95% of products 

in FreeThink’s database have a greater value. With B, the program 

assumes the more conservative limit depending on whether the 

accelerated conditions used for the calculations are above or below the 

RH of the long-term storage conditions (B = 0.00 if long term RH below 

Figure 10  Check-on/Check-off Condition Option 

Data from 80°C/52%RH will not be used in the modelling 

Figure 11  Stability Analysis 

Data are analyzed with 

recommendations. 

Hit “Implement” to take 

recommended actions. 
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accelerated; 0.10 if above), again based on a 95% limit from FreeThink’s 

database.  

 

 

While the graphs in the Low Conversion Mode (Figure 13) look similar to 

what one would obtain from an ASAPprime® model, they do not really 

represent a model. Instead, these reflect conservative estimations to 

allow minimum shelf-life assignments. 

Arrhenius Analysis 
By right clicking from the Arrhenius tab, the user can now select a new 

option: “Arrhenius Analysis”. The “Arrhenius Analysis” window provides 

additional model diagnostics (Figure 14). The first tab, the residual graph, 

is the same as with v5. The second tab provides Time/Humidity graph(s). 

There will be two graphs when RH is used and only one when the study is 

temperature only. In the left-hand graph, the logarithm of isoconversion 

rates at each condition is plotted against RH. When multiple conditions 

have similar RH values, they are grouped in lines. These lines represent 

Arrhenius lines and in a perfect model should be parallel to each other. In 

the right-hand graph, the logarithm of isoconversion rates at each 

condition is plotted against 1/T (where T is in Kelvin). When multiple 

conditions have similar temperature values, they are grouped in lines. 

These lines represent RH dependence lines and in a perfect model should 

be parallel to each other. Conditions which show non-parallel lines may 

indicate outliers or issues with the modeling. 

 

 

 

 

 

 

 

 

Figure 14  Arrhenius and RH Graphs using ln(1/isoconversion times) [ln 

k]: Ideally all lines should be parallel 

 

The third tab from the Arrhenius Analysis option, “Model Influence” is the 

Cook’s distance. This diagnostic illustrates which conditions impact the 

results most significantly (Figure 15). The impact will depend both on how 

much leverage a point (isoconversion rate for that condition) has and how 

far off it is from where the ASAP model predicts it should be (its residual).  

 

 

 

The next “Arrhenius Analysis” option (fourth tab) is entitled “Parameter 

Influence”. This dfbeta calculation indicates how much an Arrhenius 

parameter (lnA, Ea, B) would shift if a condition was removed (Figure 16). 

The units are the same units as the value uses. As with the Cook’s distance, 

points with high influence (above or below the lines) are not necessarily 

outliers but are more influential on the final result and warrant special 

scrutiny. 

 

 

 

>99% probability of passing at 3 

years 25°C/60%RH from harshest 

condition being 11 d/80°C/50%RH 

The point at 90°C has more 

influence than the others.  

Points above red line have high 

influence. 

Figure 15  Cook’s distance is based on both leverage and 

residuals for each condition 

Figure 13  Shelf life when nothing happens: Low 

Degradant Calculation 

Non-parallel 

line may 

indicate an 

outlier 
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The final “Arrhenius Analysis” tab (fifth tab) represents “Relative Values”. 

The fitted Ea (and B) values are shown (black data point) in comparison to 

the distribution of products studied in FreeThink’s database (Figure 17). A 

product that exactly matches the average from the database will be in the 

center of the bull’s eye plot. With just temperature, the image indicates 

whether a product is greater or less than the average product with respect 

to Ea (temperature sensitivity). When RH is also used, the point represents 

the position in both axes. Points fall into different quadrants depending 

on their relative temperature (Ea) and RH (B) sensitivity. 

The color coding is as follows: 

Green: 90% of products studied 

Orange: 9% of products studied; 99% are within the orange circle 

Each line represents one half of one standard deviation.  

 

 

 

 

Arrhenius Table 
Another right-click option from the “Arrhenius” tab is the “Analysis Table” 

(Figure 18). This includes both a tabular (already in v5) and a new graphical 

view of the experimental isoconversion times at all the conditions vs. the 

model fitted isoconversion times at the same conditions, each with their 

corresponding error bars. The points can be color coded for temperature 

or humidity. Ideally, all the points are on the unity line; i.e., the model 

fitting matches the values used to build the model.  This graph provides a 

visual to check if the points fit the ASAP model within the estimated error 

bars (either from the isoconversion SD or the model fit SD).   

 

 

 

Removal of the point at 

50°C/50%RH will decrease 

Ea by 1.1 kcal/mol 

Removal of the condition 

at 60°C/80%RH will 

reduce B by 0.0014 

Data point 

correspond to 

Low Ea High B ; 

quadrant. 

Model-fitted isoconversion time is 

plotted against isoconversion times 

from the data itself. A perfect fit 

would have a line with slope 1. 

Here the darker red indicates 

higher temperature conditions. 

Figure 16  Dfbeta indicates influence of each point on the 

parameters 

Red lines indicate 

high influence limits. 

Figure 17  Comparison of data to average product 

Figure 18  Arrhenius Table: Graphical View 

Poor model fit to 

the data 


